前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT(甲级)1141.PAT Ranking of Institutions (25 分)

PAT(甲级)1141.PAT Ranking of Institutions (25 分)

作者头像
lexingsen
发布2022-02-25 08:07:04
2450
发布2022-02-25 08:07:04
举报
文章被收录于专栏:乐行僧的博客

PAT 1141.PAT Ranking of Institutions (25 分)

After each PAT, the PAT Center will announce the ranking of institutions based on their students’ performances. Now you are asked to generate the ranklist. 输入格式: Each input file contains one test case. For each case, the first line gives a positive integer N (≤10^5), which is the number of testees. Then N lines follow, each gives the information of a testee in the following format: ID Score School where ID is a string of 6 characters with the first one representing the test level: B stands for the basic level,A the advanced level andTthe top level; Score is an integer in [0, 100]; and School is the institution code which is a string of no more than 6 English letters (case insensitive). Note: it is guaranteed that ID is unique for each testee.

输出格式: For each case, first print in a line the total number of institutions. Then output the ranklist of institutions in nondecreasing order of their ranks in the following format: Rank School TWS Ns where Rank is the rank (start from 1) of the institution; School is the institution code (all in lower case); ; TWS is the total weighted score which is defined to be the integer part of ScoreB/1.5 + ScoreA + ScoreT*1.5, where ScoreX is the total score of the testees belong to this institution on level X; and Ns is the total number of testees who belong to this institution. The institutions are ranked according to their TWS. If there is a tie, the institutions are supposed to have the same rank, and they shall be printed in ascending order of Ns. If there is still a tie, they shall be printed in alphabetical order of their codes.

输入样例:

代码语言:javascript
复制
10
A57908 85 Au
B57908 54 LanX
A37487 60 au
T28374 67 CMU
T32486 24 hypu
A66734 92 cmu
B76378 71 AU
A47780 45 lanx
A72809 100 pku
A03274 45 hypu

输出样例:

代码语言:javascript
复制
5
1 cmu 192 2
1 au 192 3
3 pku 100 1
4 hypu 81 2
4 lanx 81 2

题目分析:sort的使用,测试点五是一个坑,因为每个学校的分数相当于一个加权的成绩,在前期处理的时候就应该按照浮点数处理,只有在排序的时候将其转换为整数即可。

其中使用C++11的unordered_map和unordered_set会大大提高效率,因为其底层是使用hash_table实现的,具体可以参阅C++11的新标准。

AC代码:

代码语言:javascript
复制
#include <iostream>
#include <string>
#include <vector>
#include <unordered_map>
#include <set>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn = 100010;

struct school{
    string name;
    int score;
    int sum;

    school(){}
    school(string name, int score, int sum):name(name), score(score), sum(sum){}
};

vector<school> v;
unordered_map<string, double> nameToScore;
unordered_map<string, int> nameToSumPeople;
set<string> schoolName;

void toLower(string& s){
    for(int i=0; i<s.length(); ++i){
        if(s[i]>='A' && s[i]<='Z')s[i] += 32;
    }
}

bool cmp(school a, school b){
    if(a.score!=b.score)return a.score>b.score;
    if(a.sum!=b.sum)
        return a.sum < b.sum;
    else
        return a.name < b.name;
}


int main(){
    //freopen("in.txt", "r", stdin);
    int n;
    scanf("%d", &n);
    string id, name;
    double score;
    for(int i=0; i<n; ++i){
        cin>>id;
        scanf("%lf", &score);
        cin>>name;
        toLower(name);
        schoolName.insert(name);
        nameToSumPeople[name] += 1;
        if('A'==id[0]){nameToScore[name] += score;}
        else if('B'==id[0]){nameToScore[name] += (score / 1.5);}
        else{nameToScore[name] += (score * 1.5);}
    }
    for(auto it=schoolName.begin(); it!=schoolName.end(); ++it){
        v.push_back(school(*it, (int)(nameToScore[*it]), nameToSumPeople[*it]));
    }
    sort(v.begin(), v.end(), cmp);
    cout<<v.size()<<endl;
    int rank = 1;
    cout<<rank<<" "<<v[0].name<<" "<<v[0].score<<" "<<v[0].sum<<endl;
    for(int i=1; i<v.size(); ++i){
        if(!i || v[i].score!=v[i-1].score)
            rank = i+1;
        cout<<rank<<" "<<v[i].name<<" "<<v[i].score<<" "<<v[i].sum<<endl;
    }

    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档